C++ Builder issues

Hi

I'm using Libraw 0.19.5 Release 32 bit DLL with Codegear C++ Builder 2007 32 bit

I've used its implib utility over the DLL to create an import library and am referencing libraw.h

But I always get a link error [ILINK32 Error] Error: Unresolved external '_libraw_init' referenced from H:\LIBRAW\DEBUG\UNIT4.OBJ

I've tried changing DllDef to __declspec in the header, but no joy.

So I tried using LoadLibrary() instead and always get error 193 (is not a valid Win32)...

Does anyone know how to overcome this?

Thanks

Forums: 

(guessing by filename) unit4

(guessing by filename) unit4.obj is (most likely) generated from unit4.cpp or unit4.c or something like that.
There is no file(s) with same or similar name(s) in LibRaw. So, unable to help.

-- Alex Tutubalin

C++ Builder

I've made progress - I now have it building using the C api...

I'm puzzled by this, however.

This code works:

libraw_data_t * image = libraw_init(0);
libraw_open_file(image, "IMG_0174.cr2");
libraw_unpack_thumb(image);
libraw_dcraw_thumb_writer(image, "h:\\outcr2.jpg");

The return codes from all function calls is zero, and the output file is created ok.

Yet, when I examine the image->thumbnail properties, everything is zero and the thumbnail type is LIBRAW_THUMBNAIL_UNKNOWN

I'd like to be able to process the thumbnail data without wasting time writing to disk, but it doesn't seem to be there. Yet it writes to disk ok.

Is there some other step I need to take to get to the thumbnail/preview data?

Many thanks

Andy